Напишите программу, которая считывает с клавиатуры n чисел и затем выводит ** экран сумму...

0 голосов
185 просмотров

Напишите программу, которая считывает с клавиатуры n чисел и затем выводит на экран сумму и среднее арифметическое отрицательных чисел. в паскаль


Информатика (17 баллов) | 185 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var i,n,nmb: integer;
    dg,sm: real;
begin
  sm:=0;  nmb:=0;
  write('n = ');
  readln(n);
  write('числа через пробел: ');
  for i:=1 to n do
  begin
    read(dg);
    if dg<0 then</span>
    begin
      sm:=sm+dg;
      nmb:=nmb+1;
    end;  
  end;
  writeln('сумма отрицательных чисел = ',sm);
  writeln('среднее арифметическое = ',sm/nmb);
end.    


(9.7k баллов)