Делфи, написать программу все изложено в фото

0 голосов
79 просмотров

Делфи, написать программу
все изложено в фото


image
image

Информатика (15 баллов) | 79 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var
    k, i, n, m: integer;
    p: real;

begin
    Write('m = ');
    Readln(m);
    
    for i := 1 to m do
    begin
        n := i * i;
        p := 1;
        for k := 1 to n do
            p := p * (1 + i) * i / k / k;
        
        writeln('p = ', p:10:10, ' m = ', i);
    end;
end.

(55.0k баллов)