Дано целое число,написать программу которая возводит в квадрат последнюю цифру в записи...

0 голосов
53 просмотров

Дано целое число,написать программу которая возводит в квадрат последнюю цифру в записи числа


Информатика (57 баллов) | 53 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

CLS
a:
INPUT a
IF INT(a)<>a THEN PRINT "не может быть": GOTO a
b=a-10*INT(a/10)
c=b^2
PRINT c
END

(271k баллов)
0 голосов
Pascal:
var n:longint;
begin
  write ('N = ');
  readln (n);
  writeln (sqr(n mod 10));
  readln;
end.

C++:
#include
using namespace std;

int main()
{
   int n;
   cout <<"N = ";<br>   cin >>n;
   cout <<n%10*n%10 <<endl;<br>   return 0;
}
(2.8k баллов)