Составить программу ** языке Паскаль. Спортсмен в первый день пробежал 10 км. Каждый...

0 голосов
49 просмотров

Составить программу на языке Паскаль.
Спортсмен в первый день пробежал 10 км. Каждый следующий день он увеличивал дневную норму на 10% от нормы предыдущего дня. Через сколько дней спортсмен будет пробегать более 20 км в день?


Информатика (25 баллов) | 49 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var s:real; n:integer;
begin
s:=10;
n:=1;
while s<20 do<br> begin
 s:=s*1.1;
 n:=n+1;
 end;
writeln(' n = ',n);
end.

Результат:
n = 9

(194k баллов)