ИНФОРМАТИКА 9 КЛАСС ДАЮ 50 БАЛЛОВ написать программу в ABCпаскаль которая вычислит сумму...

0 голосов
43 просмотров

ИНФОРМАТИКА 9 КЛАСС ДАЮ 50 БАЛЛОВ
написать программу в ABCпаскаль
которая вычислит сумму цифр пятизначного числа и определит находится ли эта сумма в диапазоне от 20 до 25 включительно(<= или >=)


Информатика (1.2k баллов) | 43 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var
  i, c: int64;
  s: string;
 begin
  readln(s);
  if(s.Length = 5) then
begin
    for i := 1 to 5 do
      c := c + strtoint(s[i]);
    writeln(c);
    if(c >= 20) and (c
    else write('Не находится');
  end;
end.

(6.9k баллов)
0

что-то неправильно

0

что именно?

0

что-то

0

но она не идет

0

И почему ты отметил мое решение как нарушение если ты не знаешь что неправильно? Разберись сначала с заданием.