Написать программу ** паскалеИзвестно расписание поездов проходящих через станцию: -Номер...

0 голосов
89 просмотров

Написать программу на паскале
Известно расписание поездов проходящих через станцию:
-Номер поезда
-назначание(например, Москва-Омск)
-часы и минуты прибытия на станцию
-часы и минуты отправления со станции.
Поезда приходят каждый день. По данному времени определить какие поезда(номера и назначения) стоят в этот момент на станции.


Информатика (16 баллов) | 89 просмотров
0

а расписание само есть?

0

нет

0

типа самой придумать надо?

0

да

0

давай ты придумаешь и напишешь расписание, а потом я сделаю программу, а то немного лень)

0

ок

0

Номер поезда 1Назначение: Москва-ОмскЧ. и М. прибытия: 12:00Ч. и М. отправления: 12:30Номер поезда 2Назначение: Москва — Санкт-ПетербургЧ. и М. прибытия: 18:50Ч. и М. отправления: 14:30Номер поезда 3Назначение: Москва — СамараЧ. и М. прибытия:10:20 Ч. и М. отправления: 20:10

0

окей

Дан 1 ответ
0 голосов

Var h,m,t:integer;

begin
write('Введите время(ч,м): '); read(h,m);
t:=h*60+m;

writeln('В данный момент на станции стоят следующие поезда: ');
if (t>=540) and (t<590) then writeln('Номер 1, Красноярск- Москва ');<br>if (t>=570) and (t<620) then writeln('Номер 2, Новгород - Москва ');<br>if (t>=610) and (t<670) then writeln('Номер 3, С.-Петербург - Калининград ');<br>if (t>=660) and (t<720) then writeln('Номер 4, Владивосток - Москва ');<br>if (t>=720) and (t<750) then writeln('Номер 5, Москва - Омск ');<br>if (t>=755) and (t<795) then writeln('Номер 6, Томск — Москва ');<br>if (t>=780) and (t<830) then writeln('Номер 7, Москва — Екатеринбург ');<br>if (t>=820) and (t<860) then writeln('Номер 8, Москва — Самара ');<br>if (t>=845) and (t<910) then writeln('Номер 9, С.-Петербург — Москва ');<br>if (t>=890) and (t<950) then writeln('Номер 10, Москва — Красноярск ');<br>if (t>=940) and (t<990) then writeln('Номер 11, Москва — Владивосток ');<br>if (t>=980) and (t<1025) then writeln('Номер 12, Омск-Москва ');<br>if (t>=1020) and (t<1085) then writeln('Номер 13, Москва — С.-Петербург ');<br>if (t>=1080) and (t<1140) then writeln('Номер 14, Екатеринбург — Москва ');<br> end.


image
(3.2k баллов)