Помогите по блок-схеме составить программу.

0 голосов
31 просмотров

Помогите по блок-схеме составить программу.


image

Информатика (17 баллов) | 31 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

//PascalABC.Net 3.1.0.1200
var
    a, b, c, d, x, y: real;

begin
    readln(a, b, c, d);
    if a * b >= c * d then
        if a * b >= 0 then
            x := sqrt(a * b)
        else begin
            writeln('Корня нет');
            exit;
        end
    else x := c * Power(d, 1 / 3);
    
    if x < 1 then
        if a > 0 then
            y := ln(a) + c * x
        else begin
            writeln('Логарифм не существует');
            exit;
        end
    else
    if a >= 3 then
        y := c - a * x
    else
        y := b + d / x;
    
    writeln(x, ' ', y);
end.

(55.0k баллов)