Написать программу, которая вводит массив из N вещественных чисел, а затем заменяет в нём...

0 голосов
78 просмотров

Написать программу, которая вводит массив из N вещественных чисел, а затем заменяет в нём все элементы, превышающие данное число Z, этим числом. Вывести на экран полученный массив и количество замен. Протестировать программу на следующих исходных данных: а) Z=10 Массив: 1,2 2,6 3 -4,5 11 10,2 3,2 87 -15 б) Z=-2 Массив: 0 -3,1 11 -7,9 -2,1 -1,9 4


Информатика (14 баллов) | 78 просмотров
Дан 1 ответ
0 голосов

const

n=10;

var

a:array [1..n] of real;

z,i,k:integer;

begin

for i:=1 to n do 

begin

write ('A[',i,'] = ');readln(a[i]);

end;

write ('Z = ');readln(z);

for i:=1 to n do 

if a[i]>z then begin

a[i]:=z;

k:=k+1;

end;

for i:=1 to n do

if frac(a[i])=0 then write (a[i]:0:0,' ') else write (a[i]:0:1,' ');

writeln ('Kol-vo zamen: ',k);

readln;

end.

(2.8k баллов)