Помогите,пожалуйста,написать программу в Паскале через циклы while и repeat. Номер 4.

0 голосов
28 просмотров

Помогите,пожалуйста,написать программу в Паскале через циклы while и repeat.
Номер 4.


image

Информатика (95 баллов) | 28 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

1)
const eps=0.5e-6;
var x,xn,a0,a1:real;
begin
readln(x,a0);
xn:=1;
while abs(a0-a1)>=eps do
 begin
 a0:=a1;
 xn:=x*xn;
 a1:=sin(1+a0*a0*a0)/xn;
 end;
writeln(a1);
end.

2)
const eps=0.5e-6;
var x,xn,a0,a1:real;
begin
readln(x,a0);
xn:=1;
repeat
 a0:=a1;
 xn:=x*xn;
 a1:=sin(1+a0*a0*a0)/xn;
until abs(a0-a1)writeln(a1);
end.

Пример:
1.2 0.9
2.41185904021433E-006

(194k баллов)