Дан массив А(m), меньше или равно 20. Ввести на печать сумму элементов массива, Если она превосходит число 50, В противном случае вывести в печать исходный массив.
Написать программу , только прошу с интернета не брать, там программы не работают, свою программу я написала, но что-то выдаёт не так, помогите, пожалуйста.
Program mass5v;
Uses crt;
Const nmax=20;
Type mas=array[1..nmax] of integer;
Var
A: mas;
I,m,s:integer;
Am, con: text;
Begin
Clrscr;
Assign(Am,'Am.txt');
Assign(kon,'kon.txt');
Reset(Am);
Rewrite(kon);
Write('Введите размер массива m=');
Readln(m);
S:=0;
For I:=1 to m do
Begin
Read(Am, A[i]);
S:=s+A[i];
End;
Writeln;
Writeln(kon);
If s<=50 then<br> Begin
Writeln('Сумма элементов менее 50, вывод исходного массива);
For I:=1 to m do
Begin
Write('A[',i,']=',A[i],' ');
Write(kon,'A[',i,']=',A[i],' ');
End;
End
Else
Writeln('сумма элементов массива более 50 и равна: s=',s);
Close(Am);
Close(kon);
Readkey;
End.