Составьте программу, которая формирует массив из 40 случайных целых чисел от 0 до 20 и...

0 голосов
57 просмотров

Составьте программу, которая формирует массив из 40 случайных целых чисел от 0 до 20 и вычисляет:
1) среднее арифметическое нечетных чисел
2)сумму чисел, не превышающих 10
3) сумму чисел,кратных 3
На экран выводятся исходные значения и результаты вычислений


Информатика (21 баллов) | 57 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

//Dev-C++ (C)

#include
#include
#include

int main(void)
 {const int n=40;                         //количество элементов в массиве
 int arr[n],sum10=0,sum3=0;     //описание массива и инициализация сумм
 float sr=0;                                 //инициализация среднего арифметического
 srand(time(NULL));                  //чтобы каждый раз генерировались новые знач.
 printf("Array \n");
 for(int i=0;i  {arr[n]=rand()%21;                  //присваиваем элементу псевдослучайное знач.
  printf("%d ",arr[n]);                  //выводим
  sr=sr+arr[n];                            //собираем в среднем арифметическом сумму всех
  if(arr[n]<=10)<strong>                           //если элемент меньше либо равен 10 прибавляем
   sum10=sum10+arr[n];           //к соответствующему счётчику
  if(arr[n]%3==0)                       //если остаток от деления на 3 = 0 (эл. кратен 3)
   sum3=sum3+arr[n];}             //прибавляем его к соответствующему счётчику
 sr=sr/n;                                   //делим сумму всех эл. на количество эл.
 printf("\nAverage is %f\n",sr);
 printf("The sum of less than 10 is %d\n",sum10);
 printf("The sum of multiples of 3 is %d",sum3);
 return 0;}

Пример работы программы:
Array
10 0 1 14 9 14 8 8 11 10 6 11 9 6 11 4 6 6 8 6 1 15 13 4 15 0 2 12 13 19 7 1 20 4 20 6 0 18 17 18
Average is 9.075000
The sum of less than 10 is 122
The sum of multiples of 3 is 132

(38.6k баллов)
0 голосов

Const
  n=40;
var
  i,s1,s2,k:integer;
  s:real;
  a:array[1..n] of integer;
begin
  Randomize;
  Write('Сгенерированный массив: ');
  s:=0; s1:=0; s2:=0; k:=0;
  for i:=1 to n do begin
    a[i]:=Random(21);
    Write(a[i],' ');
    if a[i] mod 2<>0 then begin s:=s+a[i]; Inc(k) end;
    if a[i]<=10 then s1:=s1+a[i];<br>    if a[i] mod 3=0 then s2:=s2+a[i]
    end;
  Writeln;
  Writeln('Ср.арифм.нечетных = ',s/k);
  Writeln('Сумма не больших 10 = ',s1);
  Writeln('Сумма кратных 3 = ',s2)
end.

Пример выполнения программы
Сгенерированный массив: 14 19 1 5 0 2 1 3 2 15 5 3 18 0 4 12 5 0 9 2 14 7 18 13 0 16 9 15 19 14 13 13 16 16 1 16 14 2 1 1
Ср.арифм.нечетных = 7.9
Сумма не больших 10 = 63
Сумма кратных 3 = 102

(150k баллов)