Помогите пожалуйста! с информатикой Напишите программу, которая заполняет массив из 20...

0 голосов
323 просмотров

Помогите пожалуйста! с информатикой Напишите программу, которая заполняет массив из 20 элементов случайными числами на отрезке [100; 200] и находит в нём пару соседних элементов, сумма которых минимальна.


Информатика (120 баллов) | 323 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

Var a:array[1..20] of integer;
i,min,ind:integer;
begin 
randomize;
for i:=1 to 20 do begin
a[i]:=random(100)+100;
write(a[i]:4);
end;
writeln;
min:=a[1]+a[2];
for i:=2 to 19 do
if a[i]+a[i+1]begin 
min:=a[i]+a[i+1];
ind:=i;
end;
write('Сумма минимальна между ',ind,' и ', ind+1, ' элементом');
end.

(3.2k баллов)
0

А что такое ind?)

0

это переменная, в которую мы сохраняем значение индексов, сумма которых минимальна)

0

Её же можно назвать любой другой буквой?

0

конечно)

0

спасибо огромное!!

0

можешь еще помочь?)

0

пожалуйста

0

можешь пожалуйста помочь еще?_))))

0 голосов

C++:
for(int i = 0; i< 20; i++){
a[i]=rand()%101+100;
}
int pos=0;
for(int i = 0; i< 20; i++){
if(a[i]+a[i+1]pos=i;
}

(34 баллов)
0

А ЧЕРЕЗ ЯЗЫК ПАСКАЛЯ МОЖЕШЬ НАПИСАТЬ?

0

Очень жаль, но я его не знаю