Написать программу в Pascal, которая бы решала задачу: дано целое число A>1. Найдите...

0 голосов
22 просмотров

Написать программу в Pascal, которая бы решала задачу: дано целое число A>1. Найдите наименьшое целое неотрицательное q, при котором 5^q>A.


Информатика (16 баллов) | 22 просмотров
Дан 1 ответ
0 голосов

Var a,q:integer;
begin
readln(a);
for q:=1 to a do
if power(5,q)>a then 
begin
write(q);
break;
end;
end.

(3.2k баллов)
0

работает)