1. дано слово. удвоить в нем все буквы, стоящие ** четных местах 2. составьте программу,...

0 голосов
73 просмотров

1. дано слово. удвоить в нем все буквы, стоящие на четных местах

2. составьте программу, определяющую, на какую букву заканчивается второе слово в предложении


Информатика (49 баллов) | 73 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

for i := 1 to length(s) do

begin

    res := res + s[i];

    if i mod 2 = 0 then

       res := res + s[i];

end;

writeln(res);

 

 

i := Pos(" ",s);{ищем первый пробел}

Delete(s;i;1);{удаляем первый пробел}

i := Pos(" ",s);{ищем второй пробел, котрый теперь первый}

writeln(s[i-1]);{выдаем знак который находится перед пробелом}

 

 

 

(53.1k баллов)