Написать программу ** языке Паскаль. Вводятся размер и элементы одномерного массива A(N),...

0 голосов
30 просмотров

Написать программу на языке Паскаль. Вводятся размер и элементы одномерного массива A(N), состоящего из целых чисел. Подсчитать сумму простых чисел, оканчивающихся на 3. Результат вывести на экран.


Информатика (12 баллов) | 30 просмотров
Дан 1 ответ
0 голосов

uses crt;
Var a:array [1..100] of integer; i,n,s: integer;
Begin

Writeln('Введите размер массива'); readln(n);

For i:=1 to n do begin
                    writeln('Введите элемент массива номер  ',i); read(a[i]);
                 end;

For i:=1 to n do
    if a[i] mod 10=3 then s:=s+a[i];
    
Writeln('Сумма = ',s);

end.

 

Написано через PascalABC. Если используете другой паскаль вместо первой строчки пишите "Program 123;"

(1.7k баллов)