Написать программу, которая вычисляет среднюю (за неделю) температуру воздуха. Исходные...

0 голосов
295 просмотров

Написать программу, которая вычисляет среднюю (за неделю) температуру воздуха. Исходные данные должны вводиться с клавиатуры.

Введите температуру воздуха за неделю.
Понедельник -> 12
Вторник -> 10 '
Среда -> 16
Четверг -> 18
Пятница -> 17
Суббота -> 16
Воскресенье -> 14
Средняя температура за неделю: 14.71 град.


Информатика (12 баллов) | 295 просмотров
0

Молодец, что спросила. Баллы не пришлось тратить)

Дан 1 ответ
0 голосов

На будущее: за 8 баллов программу никто писать не будет.
Программа, возможно, не совершенна (т.е. по-любому, можно было сделать короче), однако работает. Написана на Pascal, тестировал в веб-среде PascalABC.

var mo,tu,we,th,fr,sa,su,a: ShortInt;
var b: Real;
Begin
Write('Температура воздуха в Понедельник: ');
Readln(mo);
Write('Температура воздуха во Вторник: ');
Readln(tu);
Write('Температура воздуха в Среду: ');
Read(we);
Write('Температура воздуха в Четверг: ');
Readln(th);
Write('Температура воздуха в Пятницу: ');
Readln(fr);
Write('Температура воздуха в Субботу: ');
Readln(sa);
Write('Температура воздуха в Воскресенье: ');
Readln(su);
a:=mo+tu+we+th+fr+sa+su;
b:=a/7;
Write('Средняя температура воздуха: ',b:0:2,' градусов.');
End.

(523 баллов)