Написать программу ** паскале, которая для заданных x и n вычисляет:, где n=количество...

0 голосов
49 просмотров

Написать программу на паскале, которая для заданных x и n вычисляет:
S=1-\frac{ x^{2} }{2!} + \frac{ x^{4} }{4!} - \frac{ x^{6} }{6!} +...+(-1)^{i} \frac{ x^{2i} }{(2i)!}, где n=количество членов ряда.


Информатика (175 баллов) | 49 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var
    x, a, s: real;
    n, i: integer;

begin
    write('Введите x и n ');
    readln(x, n);
    
    a := 1;
    s := a;
    for i := 1 to n do
    begin
        a := a * (-1) * x * x / (2 * i - 1) / (2 * i);
        s := s + a;
    end;
    
    writeln('S = ', s:10:3);
end.

(55.0k баллов)