напишите программу, которая выводит ** экран значение n! включая следующую функцию...

0 голосов
54 просмотров
напишите программу, которая выводит на экран значение n! включая следующую функцию function factorial (n:integer):integer; var p,i:integer; begin p:=1; for i:=1 to n do p:=p*i; factorial:=p; end;

Информатика | 54 просмотров
Дан 1 ответ
0 голосов

Var n:integer;
      ch:char;
function factorial (n:integer):longint;
  var p,i:integer; 
  begin 
    p:=1;
    for i:=1 to n do p:=p*i; 
    factorial:=p;
end;
begin
    write ('N = ');
    readln (n);
    writeln ('Factorial: ',factorial(n));
    readln;
end.

(2.8k баллов)