Напишите программу к данным заданиям и вывод ** экран (пример ** первой фотографии) **...

0 голосов
23 просмотров

Напишите программу к данным заданиям и вывод на экран (пример на первой фотографии)
На второй фотографии - задания


image
image

Информатика (1.5k баллов) | 23 просмотров
0

paskal or c++

Дан 1 ответ
0 голосов
Правильный ответ

1. 
program _1;
var a,b,s:real;
begin
writeln('Вычисление площади прямоугольника.');
writeln('Введите исходные данные:');
write('Длина(см): '); readln(a);
write('Ширина(см): '); readln(b);
s:=a*b;
writeln('Площадь прямоугольника: ',s:5:2 ,' кв.ед.');
end.

2.
program _2;
var a,b,c,v:real;
begin
writeln('Вычисление объема параллелепипеда.');
writeln('Введите исходные данные:');
write('Длина(см): '); readln(a);
write('Ширина(см): '); readln(b);
write('Высота(см): '); readln(c);
v:=a*b*c;
writeln('Объем: ',v:5:2 ,' куб.см.');
end.

3. 
program _3;
var a,b,c,s:real;
begin
writeln('Вычисление объема площади параллелепипеда.');
writeln('Введите исходные данные:');
write('Длина(см): '); readln(a);
write('Ширина(см): '); readln(b);
write('Высота(см): '); readln(c);
s:=2*(a*b+a*c+b*c);
writeln('Объем: ',s:5:2 ,' кв.см.');
end.

4.
program _4;
var a,v:real;
begin
writeln('Вычисление объема куба.');
writeln('Введите исходные данные:');
write('Введите длину ребра (см): '); readln(a);
v:=a*a*a;
writeln('Объем куба: ',v:5:2 ,' куб.см.');
end.

5. 
program _5;
var a,b,k1,k2,s:real;
begin
writeln('Вычисление стоимости покупки.');
writeln('Введите исходные данные:');
write('Цена тетради(руб): '); readln(a);
write('Кол-во тетрадей: '); readln(k1);
write('Цена карандаша(руб): '); readln(b);
write('Кол-во карандашей: '); readln(k2);
s:= a*k1+b*k2;
writeln('Стоимость покупки: ',s:5:2 ,' руб.');
end.

6.
program _6;
var a,b,k,s:real;
begin
writeln('Вычисление стоимости покупки.');
writeln('Введите исходные данные:');
write('Цена тетради(руб): '); readln(a);
write('Цена обложки(руб): '); readln(b);
write('Кол-во комплектов: '); readln(k);
s:= k*(a+b);
writeln('Стоимость покупки: ',s:5:2 ,' руб.');
end.

(3.2k баллов)