Написать программу в паскале, которая ищет корень уравнения ах+b=0

0 голосов
44 просмотров

Написать программу в паскале, которая ищет корень уравнения ах+b=0


Информатика (140 баллов) | 44 просмотров
Дан 1 ответ
0 голосов

Var
 a,b: real;
begin
 read(a,b);
 if a <> 0 then
  writeln('x = ', -b/a)
 else if b = 0 then
  writeln('Any number')
 else
  writeln('No solutions')
end.

(8.5k баллов)