Написать программу, которая выводит ответ "Верно", если число в диапазоне от 100 до 150,...

0 голосов
51 просмотров

Написать программу, которая выводит ответ "Верно", если число в диапазоне от 100 до 150, кроме 120, и "Неверно" в других случаях


Информатика (14 баллов) | 51 просмотров
Дан 1 ответ
0 голосов

Program chisloq;
uses crt;
var q: real;
begin
writeln ('Введите число');
readln (q);
if (q <150) and (q>100) and
((q>120) or (q <120)) then<br>writeln ('ВЕРНО')
else writeln('НЕВЕРНО');
end.

(3.5k баллов)
0

а почему не просто q <> 120 ?

0

ну мы в шк, покрайней мере, решали задания наподобие этого, тем способом, как я написала

0

Правда? Школа это конечно "выдающееся" заведение. Но вообще в программировании культивируется оптимальность и читабельность кода. "Неравно" в паскале обозначается "<>", в языках типа С "!=", еще видела в Lua "~="

0

ух.. всё сложно...