Вводится следующий поток данных: 7, 2, 3, -2, 4, -7, 10, 1 напишите программу по данной...

0 голосов
57 просмотров

Вводится следующий поток данных:
7, 2, 3, -2, 4, -7, 10, 1
напишите программу по данной блок-схеме и вычислите результат
ПОМОГИТЕ РЕШИТЬ. ПОЖАЛУЙСТА!!!!!!!!!


image

Информатика (20 баллов) | 57 просмотров
Дано ответов: 2
0 голосов
Правильный ответ
var n,s,k,i:integer;
a:array[1..10] of integer;
begin
readln(n);
s:=0; k:=0;
for i:=1 to n do
begin
read(a[i]);
s:=s+a[i];
if a[i] mod 2 = 0 then k:=k+1;
end;
writeln(s,' ',k);
end.

Пример:
7
2 3 -2 4 -7 10 1
11 4
(194k баллов)
0 голосов

Var
  n,s,k,a,i:integer;
begin
  Read(n);
  s:=0; k:=0;
  for i:=1 to n do begin
    Read(a);
    s:=s+a;
    if a mod 2=0 then Inc(k)
    end;
  Writeln(s,' ',k)
end.
   
Результат
7 2 3 -2 4 -7 10 1
11 4

(150k баллов)