Помогите пожалуйста написать программу си++ задан массив целых чисел вычислить сумму...

0 голосов
21 просмотров

Помогите пожалуйста написать программу си++
задан массив целых чисел вычислить сумму отрицательных элементов этого массива и определить их количество


Информатика (155 баллов) | 21 просмотров
Дан 1 ответ
0 голосов
#include
using namespace std;
int main()
{
int n, sum,howmuch;
sum = howmuch = 0;
cout << "Введите количество элементов массива" << endl;<br> cin >> n;
int a[n];
for(int i =0; i < n; i++){
cout << "Заполните массив" << endl;<br>cin >> a[i];
}

for(int i = 0; i < n; i++){
if (a[i] < 0)
{
howmuch++;
sum += a[i];
}
}
cout << "Сумма отрицательных элементов массива:" << sum << endl;<br>cout <<"Количество отрицательных объектов массива" << howmuch << endl;<br>return 0;
}

(1.4k баллов)