Написать программу Вывод минимального элемента массива целых чисел

0 голосов
58 просмотров

Написать программу Вывод минимального элемента массива целых чисел


Информатика (14 баллов) | 58 просмотров
Дано ответов: 2
0 голосов

const

  n=15;

var

  a:array [1..n] of integer;

  i,min:integer;

begin

  for i:=1 to n do

   begin

    write ('A[',i,'] = ');readln(a[i]);

   end;

  min:=a[1];

  for i:=2 to n do

   if a[i]

  writeln ('Min: ',min);

  readln;

end.

(2.8k баллов)
0 голосов

uses crt;

var

  a:array[1..100] of integer;
  i,min:integer;
begin

  randomize;
  write('Введи количество элементов массива: '); read(i);
  min:=100;

  clrscr;
  writeln('Массив: ');
  for i:=1 to i do
  begin
    a[i]:=random(10)-9;
    write(a[i]:4);
    if a[i]  end;
  writeln;
  write('Минимальный элемент массива: ',min);
end.

(7.2k баллов)