Напишите программу, которая вычисляет сумму всех делителей заданного натурального числа n...

0 голосов
135 просмотров

Напишите программу, которая вычисляет сумму всех делителей заданного натурального числа n и находит все нечётные делители этой суммы.
Входные данные
В первой строке входного файла Input.txt содержится одно целое число N(1<=N<=6*10в8степени)<br> Выходные данные
В выходной файл Output.txt вывести все нечётные делители в порядке возростания.


Информатика (56 баллов) | 135 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

//PascalABC.NET 3.2 сборка 1318

Var
  f:text;
  n,sum,i:integer;
begin
assign(f,'Input.txt');
reset(f);
read(f,n);
close(f);
for i:=1 to n do
  if n mod i=0 then sum:=sum+i;
assign(f,'Output.txt');
rewrite(f);
for i:=1 to sum do
  if (sum mod i=0) and (odd(i)) then write(f,inttostr(i)+' ');
close(f);
end.

Пример содержимого Input.txt:
4
Пример содержимого Output.txt:
1 7

(38.6k баллов)