Напишите программу, которая считывает целое число и выводит текст, аналогичный...

0 голосов
294 просмотров

Напишите программу, которая считывает целое число и выводит текст, аналогичный приведенному в примере (пробелы важны!):
Входные данные

Вводится целое число (гарантируется, что число находится в диапазоне от -1000 до +1000).
Выходные данные

Выведите две строки, согласно образцу.
Примеры:
входные данные

179

выходные данные

The next number for the number 179 is 180.
The previous number for the number 179 is 178.


Информатика (165 баллов) | 294 просмотров
0

Хотя бы указывайте какой язык программирования.

0

С++

0

cin>>k;

0

cin >> k; cout << "The next number for the number "<<k<<" is " << k + 1 << "."; cout << "The previous number for the number "<<k<<" is " << k - 1<< ".";

Дан 1 ответ
0 голосов
Правильный ответ

Var
    a: integer;

begin
    readln(a);
    writeln('The next number for the number ', a, ' is ', a + 1, '.');
    writeln('The previous number for the number ', a, ' is ', a - 1, '.');
end.

(55.0k баллов)