Напишите программу в паскале. Дано: Дан порядковый номер дня года (отсчет идет с 1-го...

0 голосов
76 просмотров

Напишите программу в паскале. Дано:
Дан порядковый номер дня года (отсчет идет с 1-го января). Требуется вывести номер дня недели этого дня, если 1 января — понедельник. (Запрещено использовать команду if)
При решении этой задачи нельзя использовать любой из видов условной инструкции if.


Информатика (49 баллов) | 76 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var n,k:integer;
begin
readln(n);
k:=(n-1) mod 7 + 1;
writeln(k);
end.

Пример:
29
1

(194k баллов)