Пожалуйста, помогите написать программу в Паскаль. 7 задача

0 голосов
32 просмотров

Пожалуйста, помогите написать программу в Паскаль. 7 задача


image

Информатика (95 баллов) | 32 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

Var
  k,i,j,t:integer;
  a:array[1..3] of integer;
begin
  Write('k='); Read(k);
  a[1]:=k mod 10;
  t:=k div 10;
  a[2]:=t div 10;
  a[3]:=t mod 10;
  for i:=1 to 2 do
    for j:=i+1 to 3 do
      if a[i]>a[j] then begin t:=a[i]; a[i]:=a[j]; a[j]:=t end;
  Write('Цифры числа ',a[1],',',a[2],',',a[3],' ');
  if a[3]-a[2]=a[2]-a[1] then Writeln('образуют арифметическую прогрессию')
  else Writeln('не образуют арифметическую прогрессию')
end.
 
Пример работы программы
k=915
Цифры числа 1,5,9 образуют арифметическую прогрессию

(150k баллов)
0 голосов

Var
 k:integer;
 t:boolean;
begin
 read(k);
 t := (k div 100 - k div 10 mod 10) = (k div 10 mod 10 - k mod 10);
 if t then
   writeln('Образуют')
 else
   writeln('Не образуют')
end.

(8.5k баллов)
0

Безусловно. Только Вы её интерпретируете так, чтобы максимально упростить решение. Это все равно, как если при решении уравнения заранее заявить, что все корни могут быть только целыми.

0

Это не одно и то же. А так, да, не вижу смысла что-то усложнять

0

Ну да, у Вас "образуют ли цифры..." и "образуют ли следующие в порядке написания в исходном числе цифры..." - это одно и то же.

0

Впрочем, никогда не любил спорить с людьми упрямыми, ибо известно в народе, что "Упрямство - мудрость [если не знаете кого, найдите в Интернет]"

0

"образуют ли цифры..." и "можно ли из цифр составить прогрессию...". Число уже задает некоторый порядок

0

Число - поставщик цифр, не более того.

0

У нас алфавит - поставщик букв. Но мы же не уверяем, что из первых десяти букв алфавита нельзя получить слова на том основании, что они следуют в определенном порядке!

0

Можно получить слова != образуют слова.

0

Это возражение ради процесса возражения? Как я понимаю, на деле-то крыть нечем.

0

Я просто поясняю, почему выбрал именно такой вариант. Не понимаю, что я должен /крыть/, если вы в самом начале согласились, что задача имеет более одной интерпретации, а я согласился с тем, что этот вариант действительно более простой.