Написать программу, которая решает уравнение ax + b < 0 относительно x для любых чисел a...

0 голосов
71 просмотров

Написать программу, которая решает уравнение ax + b < 0 относительно x для любых чисел a и b, введёных с клавиатуры.


Информатика (14 баллов) | 71 просмотров
Дан 1 ответ
0 голосов

ax + b < 0
ax < -b<br>  x < - b / a

Целые числа.
Язык программирования: Паскаль

var
a, b : integer;
begin 
readln (a); 
readln (b);
if (a = 0) and (b < 0) then
writeln ('x - любое число');
if (a = 0) and (b >= 0) then
writeln ('нет решений');
if a <> 0 then
writeln ('x < ', - b / a) 
end.

(2.5k баллов)