Помогите написать программу в паскале. За ранее спасибо. Задача ** двумерный...

0 голосов
42 просмотров

Помогите написать программу в паскале. За ранее спасибо. Задача на двумерный массив.

Задание 2.
Заполнить двухмерный массив NM [1..5,1..5] константами:

100 101 102 103 104
200 201 202 203 204
300 301 302 303 304
400 401 402 403 404
500 501 502 503 504


Информатика (15 баллов) | 42 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

Program Vovka9673;
uses crt;
const
  n=5;
var
  nm:array[1..n,1..n] of integer;
  i,j:integer;
begin
  writeln('*** alphaues is thinking... ***');
  writeln('***          OK             ***');
  writeln();
  for i:=1 to n do
    begin
      for j:=1 to n do
        begin
          nm[i,j]:=i*100+j-1;
          write (nm[i,j]:5)
        end;
      writeln();
    end;
end.

(52.6k баллов)
0 голосов

uses crt;
const
nm:array[1..5,1..5] of integer=
((100,101,102,103,104),
(200,201,202,203,204),
(300,301,302,303,304),
(400,401,402,403,404),
(500,501,502,503,504));
var
n,m:integer;
begin
for n:=1 to 5 do
begin
for m:=1 to 5 do
write(nm[n,m]:6);
writeln;
end;
end.

(7.2k баллов)