Напишите программу, которая по исходному пятизначному числу находит сумму квадратов цифр...

0 голосов
485 просмотров

Напишите программу, которая по исходному пятизначному числу находит сумму квадратов цифр данного числа

Пример ввода
12345

Пример вывода
55
С++ ПРОГРАММА


Информатика (165 баллов) | 485 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

//Dev-C++ 5.11

#include
#include
using namespace std;

int main(void)
 {int n=0;
 float sum=0;
 cin>>n;
 for(int i=0;i<5;i++)<br>  {sum+=pow(n%10,2);
  n=n/10;}
 cout<<sum;<br> return 0;}

Пример ввода:
11112
Пример вывода:
8

(38.6k баллов)