Помогите написать программу ** языке С++: Из данной строки удалить все цифры и малые...

0 голосов
54 просмотров

Помогите написать программу на языке С++: Из данной строки удалить все цифры и малые латинские буквы


Информатика (58 баллов) | 54 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

//Dev-C++ 5.11

#include
#include
using namespace std;

int main(void)
 {string s;
 int i=0,k=0;
 cin>>s;
 k=s.length();
 while (k!=i)
  {if((s[i]>='0'&&s[i]<='9')||(s[i]>='a'&&s[i]<='z'))<br>   s.erase(s.begin()+i);
  else
   i++;
  k=s.length();}
 cout<<endl<<s;<br> return 0;}

Пример ввода:
WaTerMeL1oN
Пример вывода:
WTMLN

(38.6k баллов)