1)Напишите программу,в которой вводится символ,если он находится в интервале '0'. . ....

0 голосов
61 просмотров

1)Напишите программу,в которой вводится символ,если он находится в интервале '0'. . . '9',то на экран выводится его код,в противном случае на экран
выводятся следующие за ним 2 символа
2)Напишите программу,которая при вводе латинской прописной буквы выводит на экран такую же букву,но строчную
НА ПАСКАЛЕ!!!!!!!
ПОМОГИТЕ ПОЖАЛУЙСТА!


Информатика (112 баллов) | 61 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

//PascalABC.Net 3.1.0.1200
var
    c: char;

begin
    readln(c);
    
    if c in ['0'..'9'] then
        writeln(ord(c))
    else
        writeln(chr(ord(c) + 1), chr(ord(c) + 2));
    
    if c in ['A'..'Z'] then
        writeln(LowCase(c));
end.

(55.0k баллов)