(Составьте программу паскаль) Уличный продавец газет получает а рублей с продажи каждой...

0 голосов
53 просмотров

(Составьте программу паскаль) Уличный продавец газет получает а рублей с продажи каждой из первых 50 газет. С продажи каждой из остальных газет он получает на 20% больше. Вычислите дневной заработок продавца, продающего k газет в день.


Информатика (55 баллов) | 53 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

//PascalABC.NET 3.2 сборка 1318

Var
  a,res:real;
  k,i:integer;
begin
readln(a,k);
res:=0;
for i:=1 to k do
  if i<=50 then res:=res+a else res:=res+a*1.2;<br>writeln(res);
end.

Пример ввода:
10
51
Пример вывода:
512

(38.6k баллов)