Программа, которая вычисляет сумму всех делителей заданного натурального числа N и...

0 голосов
80 просмотров

Программа, которая вычисляет сумму всех делителей заданного натурального числа N и находит все нечетные делители этой суммы.
Входные данные - в первой строке входного файла input.txt cсодержится число N(1<=N<=6*10^8)<br> Выходные данные -в выходной файл Output,txt вывести все нечетные делители в порядке возрастания.
пример - input.txt = 10, output.txt = 1 3 9


Информатика (15 баллов) | 80 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

//PascalABC.NET 3.2 сборка 1318

Var
  f:text;
  n,sum,i:integer;
begin
assign(f,'Input.txt');
reset(f);
read(f,n);
close(f);
for i:=1 to n do
  if n mod i=0 then sum:=sum+i;
assign(f,'Output.txt');
rewrite(f);
for i:=1 to sum do
  if (sum mod i=0) and (odd(i)) then write(f,inttostr(i)+' ');
close(f);
end.

Пример содержимого Input.txt:
4
Пример содержимого Output.txt:
1 7

(38.6k баллов)