Ниже на пяти языках программирования записан алгоритм. Получив на вход число x, этот алгоритм печатает число M. Известно, что x > 150. Укажите наименьшее такое (т. е. большее 150) число x, при вводе которого алгоритм печатает 30.
var x, L, M: integer;
begin
readln(x);
L := 2*x-30;
M := 2*x+30;
while L <> M do begin
if L > M then
L := L - M
else
M := M - L;
end;
writeln(M);
end.