Информатика. Напишите программу для решения данного выражения (фото прикреплено)

0 голосов
36 просмотров

Информатика. Напишите программу для решения данного выражения (фото прикреплено)


image

Информатика (22 баллов) | 36 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

В стандартном Паскале нет функции десятичного логарифма, поэтому воспользуемся соотношением lg(x) = ln(x) / ln(10).
Кроме того, показатель степени у числа "е" (-x² / 2xy) можно упростить до -x / 2y.

var
  a,x,y:real;
begin
  Write('Введите x и у через пробел: '); Read(x,y);
  a:=1e5*Ln(Abs(0.8*x))/Ln(10)*Exp(-x/(2*y));
  Writeln('a=',a)
end.

(150k баллов)