Нужно сделать в паскалеНа столе лежит кучка монет. В этой кучке ровно N монет, каждая из...

0 голосов
71 просмотров

Нужно сделать в паскале
На столе лежит кучка монет.
В этой кучке ровно N монет, каждая из которых имеет стоимость A[i].
Можно выбрать только 3 монеты из кучки. Ваша задача определить максимальную сумму, которую можно набрать?
Формат ввода:В первой строке находится число N - количество монет в кучке. Далее следует N целых чисел A[i] - стоимость i-той монеты.
0 <= A[i] <= 10 <br>3 <= N <= 10<br>
Формат вывода:Одно число - ответ на задачу.


Информатика (182 баллов) | 71 просмотров
Дан 1 ответ
0 голосов

Программа написана на языке Паскаль.
uses crt;
var
m, n,t, i : integer;
a : array [1..10] of integer;
max : array [1..10] of integer;
begin
clrscr;
m := -100;
write ('N ='); readln (n);
for i:= 1 to n do 
read (a[i]);
for i:= 1 to n do
if a[i]>=m then begin
max[1]:= a[i]; m:=max[1]; end;
 for i:= 1 to n do if t<>1 then
if a[i]=max[1] then begin a[i]:=0; t:= t+1; end; 
 m:= -100;
for i:= 1 to n do
if a[i]>=m then
begin
max[2]:= a[i]; m:=max[2]; 
end;
 t:= 0;
 for i:= 1 to n do
 if t<>1 then
if a[i]=max[2] then
begin a[i]:=0; t:= t+1; end; 
 m:= -100;
for i:= 1 to n do
if a[i]>=m then
begin max[3]:= a[i]; m:=max[3]; end; 
t:= 0; 
for i:= 1 to n do if t<>1 then
if a[i]=max[3] then begin
a[i]:=0; t:= t+1; end;
  m:= -100;
 writeln;
for i := 1 to 3 do
t:= max[i]+t;
writeln ('otvet ',t);
readkey;
end.

(230 баллов)