Кто знает армянский язык?нужна помощь по информатике,Turbo Pascal

0 голосов
65 просмотров

Кто знает армянский язык?нужна помощь по информатике,Turbo Pascal


Информатика (2.0k баллов) | 65 просмотров
0

средний арифметический - (a+b)/2

0

можете помочь?

0

блок схем я не делаю.

0

и как именно формируются элементы вектора У не понятно. Вы сами понимаете?

0

а кажется дошло. элементы вектора У это такие элементы из Х которые больше среднеарифметического значения максимума и минимума вектора Х

0

da ponimayu no na armyanski

0

if x[i] > (max + min) / 2

0

da tak

0

программу могу написать, а блок схемы делать не умею

0

xorosho,

Дан 1 ответ
0 голосов
Правильный ответ

Var
    x, y: array[1..100] of integer;
    i, n, k: integer;
    min, max: integer;

begin
    {ввод массива}
    write('n = ');
    readln(n);
    
    writeln('Данные массива:');
    for i := 1 to n do
    begin
        readln(x[i]);
        
    end;
    writeln();
    
    {минимум и максимум}
    max := x[1];
    min := x[1];
    for i := 1 to n do
    begin
        if max < x[i] then max := x[i];
        if min > x[i] then min := x[i];
    end;
    writeln('max = ', max);
    writeln('min = ', min);
    writeln('avg = ', (max + min) / 2);
    
    max := (max + min) / 2;
    k := 0;
    for i := 1 to n do
    begin
        if x[i] >= max then begin
            k := k + 1;
            y[k] := x[i];
            write(y[k], ' ');
        end;
    end;
end.

(55.0k баллов)
0

bolshoe spasibo

0

не за что. и вообще для спасибо есть кнопочка)

0

помогите пожалуйста
Дано N целое число и N x N размер матрицы.
Составить блок-схему и на языке Turbo Pascal написать программу,которые подсчитают и напечатают среднее арифметическое для печати матричных элементов главной диагонали вниз, значение которых относятся данному [a;b] диапазону .

0

следующий раз кидай мне ссылку на задание в сообщении, так будет проще