Напишите программу в Delphi 7, к данной задаче или составьте математическую модель...

0 голосов
51 просмотров

Напишите программу в Delphi 7, к данной задаче или составьте математическую модель (напишите с помощью кода). Очень срочно, я не пойму это программирование ! Но нужно решить , на оценку ! Прикрепите пожалуйста в файле delphi чтобы я смог на компьютере открыть !


image

Информатика (2.0k баллов) | 51 просмотров
0

У вас не Windows 8?

0

program zadaha3b;{$APPTYPE CONSOLE}uses SysUtils; var k, l, m, n: integer;begin readln(k,l,m,n); if (k+l+m+n mod 2 = 0) then writeln('ïîëÿ îäíîãî öâåòà') else writeln('ïîëÿ ðàçíûõ öâåòîâ')end.

0

Windovs 8

0

Delphi 7

0

вводить надо через пробел или через ентер

0

ввожу через запятую

0

я воожу а чет не проверяется

0

и как координаты вводить в программе ?

0

вот это написал пока , не знаю прав или нет

Дан 1 ответ
0 голосов
Правильный ответ

Var
    k, e, m, n: integer;

begin
    readln(k, e, m, n);
    if (k + e) mod 2 = (m + n) mod 2 then
        writeln('Одного цвета')
    else
        writeln('Разных цветов');
    
    if (k = m) or (e = n) then
        writeln('Прямая ладья')
    else
        writeln('Косая ладья через ', k, ',', n);
end.

(55.0k баллов)
0

а он ошибку в конце выдает

0

попробуй так. одно число за раз

0

Invalit nomerik imput

0

а теперь ввожу цифры 1 2 3 4 и она вообще быстро закрывается черное окно

0

если вводить через пробел то числа просто в строчку пишутся бесконечно , я ввожу так цифра интер цифра интер цифра интер цифра интер потом вылезает окно с ошибкой

0

просто 4 числа это как именно?

0

какую ошибку?

0

цифра пробел цифра пробел цифра пробел цифра

0

я ввожу просто 4 числа

0

var
k, e, m, n: integer;

begin
write('введите координату = ');read(k);
write('введите координату = ');read(e);
write('введите координату = ');read(m);
write('введите координату = ');read(n);
if (k + e) mod 2 = (m + n) mod 2 then
writeln('Одного цвета')
else
writeln('Разных цветов');

if (k = m) or (e = n) then
writeln('Прямая ладья')
else
writeln('Косая ладья через ', k, ',', n);
end.