Написать программу ** Pacal ABC и составить блок-схему этой программы.Задание: проверить...

0 голосов
55 просмотров

Написать программу на Pacal ABC и составить блок-схему этой программы.
Задание: проверить истинность высказывания: "Все цифры данного трехзначного числа различны"
Программа должна выводить либо True либо False. (с помощью типа: boolean)
Зараннее спасибо!



Информатика (78 баллов) | 55 просмотров
Дан 1 ответ
0 голосов

uses crt;
var
  x:integer;
  y:boolean;
begin
  clrscr;
  write('Введите трехзначное число'); read(x);
  y:=((x mod 10)<>(x div 100))and
   ((x div 100)<>(x mod 100 div 10))and
   ((x mod 10)<>(x mod 100 div 10));
  write(y);
end.


image
(7.2k баллов)