Помогите пожалуйста с информатикой. 7 класс. Turbo Pascal Задача №1:Составить программу,...

0 голосов
117 просмотров

Помогите пожалуйста с информатикой.

7 класс. Turbo Pascal

Задача №1:Составить программу, которая преобразует введённое с клавиатуры дробное число в денежный формат (12.5 в 12 рублей 50 копеек).

a - исходные данные

x,y - результаты

trunc (12,5)=12

frac (12,5) =0.5

0.5*100=50.0

trunc (50.0)=50

Задача №2: Составить программу, вычисляющую сумму цифр трёхзначного числа n.

n - трёхзначное число (напр.762) - исходные данные

a,b,c - цифры этого числа

Задача №3: Программа находит из А и В большее.

а,b - исходные

c - результат

Задача №4: С кондитерской фабрики разгружают конфеты в коробках по 10 кг, 5 кг и 1 кг. Какое наименьшее количество коробок потребуется для перевозки N килограмм конфет?

Задача №5:

int(-5,89)

int(0,53)

round(-5,8)

round(5,2)

frac(-17,4)

frac(0,32)

trunc(-17,4)

trunc(15,2)

45 div 4

15 mod 8

(489 div 10) mod 10


Информатика (7.4k баллов) | 117 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

1)

var

  a: real;

  x, y: integer;

 

begin

  writeln('Введите дробное число');

  readln(a);

  x:= trunc(a);

  y:= frac(a);

  writeln(x, ' рублей ', y * 100, ' копеек');

  readln;

end.

2)

var

  n: 100..999;

  a, b, c: 0..9;  //a - сотни, b - десятки, с - единицы

 

begin

  writeln('Введите трехзначное число');

  readln(n);

  a:= n div 100;

  b:= (n mod 100) div 10;

  c:= n mod 10;

  writeln('Сумма цифр:  ', a + b + c);

  readln;

end.

3)

var

  a, b, c: real;

 

begin

  writeln('Введите числа а и b');

  readln(a, b);

  if a > b then

  begin

    c:= a;

    writeln(c, ' - большее число');

  end;

  if b > a then

  begin

    c:= b;

    writeln(c, ' - большее число');

  end;

  if b = a then writeln('Числа равны');

  readln;

end.

 

  

 

(2.1k баллов)