Напишите программу ** языке паскаль.богатый и бедный заключили спор .богатый отдает...

0 голосов
41 просмотров

Напишите программу на языке паскаль.богатый и бедный заключили спор .богатый отдает каждый день 100 в течение месяца .бедный отдает в первый день копейку каждый следующий день в 2 раза больше в течение месяца ,кто выграет спор


Информатика (17 баллов) | 41 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var m1,m2,st,i:integer;
begin
m1:=0; m2:=0;
st:=1;
for i:=1 to 30 do
 begin
 m1:=m1+100;
 m2:=m2+st;
 st:=st*2;
 end;
writeln('Богатый: ',m1,'  бедный: ',m2);
if m1 then writeln('Выиграл богатый') else writeln('Выиграл бедный');
end.

Результат:
Богатый: 3000  бедный: 1073741823
Выиграл богатый

(194k баллов)