9 КЛАСС Напишите программу в паскале/делфи (без разницы) подсчета суммы:...

0 голосов
85 просмотров

9 КЛАСС Напишите программу в паскале/делфи (без разницы) подсчета суммы:
1)1/2+(1*2)/4+(1*2*3)/6+ и т.д
2)(x-4)/4^1 + (x+8)/8^2 + (x-12)/12^3 + и т.д
3)4/2+8/2^2+16/2^3+ и т.д


Информатика (334 баллов) | 85 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var
    i, n, temp: integer;
    s, x: real;

begin
    read(n, x);
    s := 0;
    temp := 1;
    for i := 1 to n do
    begin
        temp := temp * i;
        s := s + temp / (2 * i);
    end;
    writeln(s);
    
    s := 0;
    temp := 1;
    for i := 1 to n do
    begin
        temp := temp * (-1);
        s := s + (x + temp * 4 * i) / exp(i * ln(4 * i));
    end;
    writeln(s);
    
    s := 0;
    for i := 1 to n do
    begin
        s := s + 2;
    end;
    writeln(s);
end.

(55.0k баллов)
0

Здравствуйте! Не могли бы вы еще помочь с одним?

0

(5+x^2)/sqrt(6) - (6-x^4)/sqrt(7) + (7+x^6)/sqrt(8)- и т.д. Буду благодарна

0

а функции использовать можно?

0

можно

0

function Power(x, n: real): real;
begin
Power := exp(n * ln(x));
end;

var
i, n, temp, sign: integer;
s, x: real;

begin
read(n, x);
s := 0;
temp := 4;
sign := -1;

for i := 1 to n do
begin
sign := sign * (-1);
temp := temp + 1;
s := s + sign * (temp + Power(x, Power(2, i))) / sqrt(temp + 1);
end;

writeln(s);
end.

0

огромное спасибо