1)Дано целое число N.Написать программу,заменяющую его 1,если число меньше нуля,и...

0 голосов
55 просмотров

1)Дано целое число N.Написать программу,заменяющую его 1,если число меньше нуля,и увеличивающую его на 6,если число больше или равно нулю.
2) Даны два числа a и b.Написать программу,которая выводит номер большего из них


Информатика (12 баллов) | 55 просмотров
Дан 1 ответ
0 голосов

1) program chislo1
uses crt
var a: longint;
begin
clrscr;
writeln ('введите целое число');
readln(a);
if a<0 then a:=1<br>else a:=a+6;
writeln (a);
end.
2) program chislo2
uses crt
var a,b: longint;
begin
clrscr;
writeln ('введите два числа через пробел');
readln(a, b);
if a>b then
writeln (a)
else
writeln (b);
end.





(3.5k баллов)
0

надо вывести само число

0

"номер большего из них"

0

номер не есть значение

0

пользователь вводит 2 числа, первое в переменной а - это само число, которое вводили первым...

0

ааа... всё... тогда программа не верна...

0

не посмотрела ранее

0

школьные задачки такие путанные, часто приходится переспрашивать учителя, чтоб понять , что именно от тебя хотят

0

вот вот. полностью с тобой согласна

0

значит последние 4 строчки будут следующие:

0

writeln('1') else writeln('2'); end.