Составьте программу, которая выводит ** экран пример ** умножение двух целых чисел,...

0 голосов
25 просмотров

Составьте программу, которая выводит на экран пример на умножение двух целых чисел, запрашивает ответ пользователя, проверяет его и выводит соответствующее сообщение: "Правильно!" либо "Вы ошиблись", а также правильный результат.


Информатика (19 баллов) | 25 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var
    a, b: integer;

begin
    a := Random(10);
    b := Random(10);
    write(a, ' * ', b, ' = ');
    a := a * b;
    readln(b);
    
    if a = b then writeln('Правильно')
    else writeln('Не верно. Правильный ответ ', a);
end.

(55.0k баллов)