Напишите программу ** языке программирования (или составьте алгоритм). Дано натуральное...

0 голосов
51 просмотров

Напишите программу на языке программирования (или составьте алгоритм). Дано натуральное число n. Определите, сколько раз цифра «7» встречается в записи данного числа.


Информатика (18 баллов) | 51 просмотров
Дан 1 ответ
0 голосов

var
a,b,k:integer;
begin
write('Введите число: ');
readln(a);
k:=0;
while a<>0 do
begin
  b:= a mod 10;
  a:= a div 10;
  if b=7 then k:=k+1;
end;
writeln(k);
end.

(1.1k баллов)