Вопрос по информатике напишите программы в pascale для такой задачи 1.Петя впервые пришел...

0 голосов
250 просмотров

Вопрос по информатике
напишите программы в pascale для такой задачи
1.Петя впервые пришел на урок физкультуры в новой школе. Перед началом урока ученики выстраиваются по росту, в порядке невозрастания. Напишите программу, которая определит, на какое место в шеренге Пете нужно встать, чтобы не нарушить традицию, если заранее известен рост каждого ученика и эти данные уже расположены по невозрастанию (то есть каждое следующее число не больше предыдущего). Если в классе есть несколько учеников с таким же ростом, как у Пети, то программа должна расположить его после них.

Сначала задано число N учеников. Потом введены росты учеников в количестве
N (росты не превышают 200). Затем, на
новой строке, вводится рост самого Пети.

Программа должна вывести единственное число — номер Пети
в шеренге учеников


Информатика (55 баллов) | 250 просмотров
0

А какие еще задачи есть, кроме этой? У Вас в вопросе написано "... для таких задач", т.е. во множественном числе.

0

сейчас выложу

0

Видите ли, по нашим правилам комментарий может только пояснять содержание вопроса, но никак не расширять его. В вашем же случае комментарий вводит дополнительные задания, что недопустимо. Так что Вам надлежит, если такое желание есть, внести изменение в текст вопроса.

0

я изменил вопрос

0

И сколько программ Вы просите написать к задаче?

Дан 1 ответ
0 голосов
Правильный ответ

// PascalABC.NET 3.1, сборка 1256 от 21.06.2016
begin
  var n:=ReadInteger();
  var a:array of integer;
  a:=ReadArrInteger(n);
  var p:=ReadInteger();
  Sort(a);
  var i:=n-1;
  while a[i]>p do Dec(i);
  Writeln(i+2);
end.

Тестовое решение:
5
175 169 172 180 174
174
4

(142k баллов)
0

большое спасибо

0

Пожалуйста. Замечу только, что для "Спасбо" тут есть специальная кнопочка.