Срочно. Нужно написать программу, в которой будет выводиться сумма всех чисел, в которых...

0 голосов
34 просмотров

Срочно. Нужно написать программу, в которой будет выводиться сумма всех чисел, в которых есть повторяющиеся цифры (например 22,33,44,100,101,202,110,202 и т.д). Так до 10000. Прошу, очень срочно. Можете хоть на паскале, где угодно. Только укажите в своем ответе программу, на которой писали.


Информатика (15 баллов) | 34 просмотров
0

Pascal это программа?

0

Вы издеваетесь?

0

Вам все равно какой язык программирования или что?

0

Да, все равно, главное результат

0

число 2334 подходит?

0

Ответ уже есть, всем спасибо)) Ответ - 24717105

0

s = 24727105

Дан 1 ответ
0 голосов
Правильный ответ

Программа на паскале:
var a,c,s:integer;
m:set of 0..9;
b:boolean;
begin
s:=0;
for a:=10 to 10000 do
 begin
 m:=[];
 b:=false;
 c:=a;
 while c<>0 do
  begin
  if (c mod 10) in m then b:=true;
  m:=m+[c mod 10];
  c:=c div 10;
  end;
 if b then s:=s+a;
 end;
writeln('s = ',s);
end.

Результат:
s = 24727105

(194k баллов)