Начертите блок схему и напишите программу ** языке Pascal для решения следующей задачи:...

0 голосов
64 просмотров

Начертите блок схему и напишите программу на языке Pascal для решения следующей задачи: вычислите длину окружности и площадь круга еслм дан радиус r.


Информатика (39 баллов) | 64 просмотров
Дано ответов: 2
0 голосов

если что:

S - площадь круга

R -  радиус (по формуле)

r - значение радиуса, которое тебе дано

ну и формула площади круга: пи*R^2 


image
(14 баллов)
0 голосов
Программа:

const pi = 3.141592653589793;
var r, s, l: real;
begin
  write('r = '); read(r);
  l := 2 * pi * r;
  s := pi * r * r;
  writeln('l = ', l:0:2);
  writeln('S = ', s:0:2);
end.
image
(13.3k баллов)
0

"Начертите блок схему..."

0

Эх, думал никто не заметит :)

0

"Ибо сказано: Бди!" )))